HF99 Interactive Requirements

  • Quicktime 4.1
  • Fast internet connection (LAN or high speed cable modem / DSL)
  • Internet Explorer 4.5 or later -or- Netscape 4.7 or later

If you have problems viewing this, drop us a mail describing your problem.

Thanks,